why do some web pages load slowly

\"\"

But I cannot figure out why. I have tried adjusting browser settings, clearing cache, clearing the extensions. My PC is Virus and Trojan free. I know its not my ISP, because when I play league of legends on my PC or any other online game, it loads up VERY FAST and connects to the server quickly, with no lag solid ping. Ive done speed tests on the speed test sites and everything is normal
Also. Netflix on all my wired and wireless devices runs smooth. All my other devices in the house (Phones, laptops, tablets) that can load webpages are loading them at blazing speeds when hooked wired and wirelessly to the same router. I built this PC myself and its always been speedy. Something happened out of nowhere. Heres another odd discovery too. certain web pages are loading improperly now as well. facebook takes like 10 mins to load, and when it does, its all text and no images.

Youtube\’s formatting is way off as well and loads slow. Every webpage is taking a good amount of time to load up. Here\’s another odd thing. I wanted to test something out. so I went to a proxy server website to try and load websites through one of their search bars. the weirdest thing. everything loaded super fast and was formatted properly, yet when I use any of my browsers as normal, its slow as molasses out of no where. The only thing I could find doing searches (which take forever because google also runs super slow now) is that it may be a DNS problem. Anyone have any clue? Weird huh? Its the same way no matter what browser I use. Literally almost every website takes about 60 seconds to load. It is really weird. I have read through various topics here. but none of them I think have some of the same circumstances (yes the slow loading, but in addition to the pages loading awkwardly as well as the proxy server situation.

I thought it would be interesting) If it helps I have a linksys E3200 router. I just felt it. its kind of warm. but I dont think thats it since al my other devices are working excellent when loading pages. My PC is the only one hard wired in though I also use Bit defender as my Anti-Virus protection, and there\’s no malware spyware or anything as I said before. I tried running the troubleshooting in Windows 7 on the network, it found no issues, I tried to run in for specific sites. it found no issues. I have re-started my router, and my modem, my PC. The only thing I havent done is change my router settings. but once again. that cant be it because its this PC only thats having the problems This has been going on for about a week. and it seems to get slower and slower.

Edited by playgroundlegend, 21 October 2014 – 01:33 AM. A. I SEE WHERE YOU ARE COMING FROM ON THIS. MY OTHER PC, ALSO XPSP3 WITH IE8, EVEN OLDER, WHEN PLUGGED INTO THE ROUTER LOADS THE PROBLEM PAGES JUST FINE. I CHECKED ALL THE CABLES, SWAPPING THEM AROUND TO SEE IF I HAD A BAD CABLE. I STARTED OUT WITH AN OLDER LINKSYS G ROUTER, BOUGHT A NEW NETGEAR N600 GIGABIT ROUTER THAT CHANGED NOTHING, RETURNED AND EXCHANGED THAT NEW ROUTER FOR THE BELKIN N750 GIGABIT ROUTER CURRENTLY IN USE. PLEASE LET ME KNOW IF YOU FEEL STRONGLY THAT I SHOUD REPOST NETWORKING? I WISH I HAD A NETWORK CARD LAYING AROUND I COULD TRY AS PERHAPS THE ONBOARD CONTROLLER TOOK A HIT? THE PC RENDERS 480i VIDEO AND BURNS DVD\’S AS QUICKLY AS EVER.

Show More

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close