why is my amp in protect mode

\"\"

THIS ARTICLE ONLY APPLIES TO AUDIOCONTROL CAR AMPLIFIERS. IF YOU HAVE ANY OTHER MANUFACTURER OF AMPLIFIER, YOU WILL NEED TO CALL THAT MANUFACTURER FOR TECH SUPPORT
If your amp has the protection light on, that means the amp has detectedPa short via the speaker connection, or has received over or under proper voltage and has put itself into protect mode. If you have an amp that is in protection mode, the first thing you want to do is turn off the amp and disconnect the power cable. You will also want to disconnect all input cables and ALL speaker cables. Leave the amp completely disconnected for a few minutes. P5 minutes tops. Reconnect the power cable, and ONLY the power cable. If the protection light does not come back on you can then start Pplugging back the input cables and applicable speaker cables. PIt s good to take it slow, when plugging back the speaker cables, it s always good practice to check both the connection on the amp AND the speaker connection.

\"\"

If you have one of our multi channel amplifiers, you may need to attach the speaker cables back zone by zone and confirm each zone is working before connecting the next zone. Since it only takes one zone to have a problem in order for the protection light to be engaged. Now, if you boot the amp back up with nothing conected to it and it STILL stays in protect, then something is wrong with the amp and you will need to contact AudioControl tech support. PVia email, or call 425-775-8461. We are open 8 am to 5 pm Monday thru Friday pacific standard time. Ever had an amp stop working and turn its \”Protect\” light for no aparant reason? Me too! This great article outlines the steps you can take at home to diagnose why your car stereo amplifier is going into protection mode. 1.

\"\"

Check amp power cables, all terminals & fuses for secure mounting and clean connections. Check ground cables securely attached to car chassis. 2. Check amp power cables for voltage using a multimeter. Connect to the + & – and confirm 12V or more. Verify 11V or more with the engine off, 12v or more with it on. 3. Check amp start wire from head-unit for voltage using a multimeter. Connect to the remote wire & -, verify 11V or more with the engine off, 12v or more with it on. 4. Check if the amp is hot. If it feels very hot (burningly hot) and goes into protection mode, verify your speakers impedence is within the amplifiers load specification. If they are, then give your amp more ventilation. 5. Remove speaker wires from amp and start up your system.

If the amp does not go into protection check the speaker cables for short circuits, cuts, breaks. If the cables are OK, check your speakers impedence with a multimeter as the speaker itself might have a short or damaged coil. If the amp continues to go into protection mode, leave the speakers disconnected and go to step 6. 6. Remove the RCA cables from amp and start up your system. Remember to tape over the exposed RCA leads so u don\’t short by accident. If the amp does not go into protection mode when u start it up you have a problem with the RCA cables or the headunit. Check the RCA leads for correct installation at the head unit and amp, check for cable damage or shorts. Consult your headunit manual for troubleshooting if the RCA\’s are OK. 7. If your amp still goes to protections then your amp needs to be serviced by a professional.

Show More

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close